OLSRd_V1 was spricht gegen aktuelle Version 0.9.6.2?


#1

Servus!

Ich habe mich mit manuellen Setups von OLSRd beschäftigt, sowohl unter Debian als auch OpenWRT.

Dabei habe ich festgestellt, dass OLSRd unter Debian mit einer mehr als 4 Jahre alten Version 0.6.6 aus den Repositories kommt, bei OpenWRT wird die aktuelle verwendet.

Bei https://github.com/vchrizz/ER-wizard-OLSRd_V1 wird nicht die aktuelle verwendet:
11/2017 fixed wizard-run: downgraded olsrd packages to version 0.9.0.3-1
Welchen Grund hat das?

Im offiziellen Wiki sind leider noch nicht die aktuellen Versionen verlinkt:
http://www.olsr.org/mediawiki/index.php/Releases

Hier ist aber die aktuelle v0.9.6.2 zu finden:
http://olsr.org/git/olsrd.git
OLSRd auf GitHub


#2

Beim EdgeRouter verwenden wir 0.9.0.3, da es in nachfolgenden Versionen Probleme mit der Stabilität in Verbindung mit Info-Plugins gab. Die neueste Version 0.9.6.2 (irgend ein commit mitten drinnen) behebt das.

Aktuell bereite ich eine neue Wizard-Version mit pre-0.9.7 vor. Die habe ich aber noch nicht rausgegeben, da ich noch etwas am GUI feile. Und die Bezeichnung “pre” macht mich etwas skeptisch, da es nicht ganz fertig klingt. Wann es “0.9.7” ohne prefix “pre” geben wird, beschweigen die olsrd Developer leider.

Falls du Interesse an einer Testausgabe des ER-Wizards mit pre-0.9.7 hast, lass es mich wissen!


#3

Verstehe, danke für die schnelle Antwort!

Also nachdem ich eh gerade dabei bin einen node aufzubauen, melde ich mich gerne freiwillig zum Testen.

Die Welt ist klein, die Antennenhalterung mit den zusätzlichen Bohrungen bekommst Du morgen zurück. :wink: